xls columns not imported

LabKey Trial Support
xls columns not imported cmarkwood  2019-04-24 10:34
Status: Closed


I've set up a cloud trial server and project and am trying to import a simple .xls file into the Laboratory Data but only half of my columns are being imported. I believe that I've set the data type correctly. Some Strings come through, others don't and it's the same with Numbers (Double).
I've tried twice with the same result.


Jon (LabKey DevOps) responded:  2019-04-25 10:09
Hello CM,

I'd like to get some more details from you so we're on the same page.

Are you using the existing Blood Test assay to upload into or did you create a new assay within the Laboratory Data section of your Trial site?

Did you make sure that the field names were spelled correctly per the assay expected data format? Or did you use the template that the assay provided? (See attached screenshot).

Also, we have an upcoming live Flash Training of LabKey Trial Server that is coming up on April 30th @ 10am PST that I think would be very beneficial for your needs and I strongly encourage you to attend this session. More about the flash training is below:

"This 30-minute flash training will help new users and teams evaluating LabKey Server familiarize themselves with the platform. User Education Director, Steve Hanson, will walk through the platform navigation and architecture basics, highlight core areas of functionality to explore during the trial period, and answer intro level questions. We recommend that all teams evaluating LabKey Server attend one of these training sessions to help them get the most out of their trial experience."



cmarkwood responded:  2019-04-25 11:16
Status: Active
Hi Jon,
My field names were incorrect. It works now. Thanks for your suggestion.
I can't make April 30th but will read the docs. I'm looking for a general assay data browser tool -- for various assay data (not trial data).