×
Maintenance Notice: labkey.org will be offline at 8:30 PM Pacific Time on Tuesday, February 27th 2024 for upgrade maintenance. The estimated downtime should be no more than 30 minutes. Please save your work before this time. We apologize for any inconvenience.

The installation process for Linux

Installation Forum (Inactive)
The installation process for Linux joesal  2019-02-13 11:13
Status: Closed
 

In the section Create Folder Structure, I'm a bit confused as to what should be <labkey-home>.

I've created the directory /usr/local/labkey, and then I've added into that directory, apps, labkey, backups, src, src/labkey, so now
I have a total of 3 labkey directories. During the installation, there's no part that has me adding anything to /usr/local/labkey/labkey, or
/usr/local/labkey/src/labkey. I've added all the jars to tomcat-lib/, then is says to copy files to the labkey home directory, which I thought
was going to be /usr/local/labkey. But I also noticed that in the docs as a description for /usr/local/labkey/labkey, it says that that's the
actual install directory of the labkey server. I don't know what that means. Also is says in the description that /usr/local/labkey/src/labkey is the place where you store the downloaded binaries, yet there's no step that outlines anything related to either. So, for all the directories that need to be moved, example labkeywebapp, modules, and pipelines-lib, do these go under /usr/local/labkey, or /usr/local/labkey/labkey? And is /usr/local/labkey considered <labkey-home>, or is /usr/local/labkey/labkey considered <labkey-home>? Also, for Linux install, does anything go under /usr/local/labkey/src/labkey?

 
 
joesal responded:  2019-02-13 11:57
Status: Active
Title: A little confused over the folder structure section of the installation doc for Linux

Anyhow, I ran through the complete installation process, where /usr/local/labkey is <labkey-home>, all the directories to be moved are at that level. I've configured <tomcat-home>/conf/Catalina/localhost/labkey.xml with docBase pointing to "/usr/local/labkey/labkeywebapp" and restart tomcat. When I go to http://<my-ec2-instance>.amazonaws.com:8080/ I get to the tomcat page fine. But if I go to http://<my-ec2-instance>.amazonaws.com:8080/labkey, I get a 404. What am I missing?

 
joesal responded:  2019-02-13 12:17

Here is some of the log info in catalina.log:

INFO [Catalina-utility-1] org.apache.catalina.startup.HostCon
fig.undeploy Undeploying context [/labkey]
13-Feb-2019 17:46:40.200 WARNING [Catalina-utility-1] org.apache.catalina.deploy.Namin
gResourcesImpl.cleanUp Failed to retrieve JNDI naming context for container [StandardE
ngine[Catalina].StandardHost[localhost].StandardContext[/labkey]] so no cleanup was pe
rformed for that container
javax.naming.NameNotFoundException: Name [comp/env] is not bound in this Context.

I'm not really sure what all of that means.

 
joesal responded:  2019-02-13 13:40

Ok, so inching my way to getting this working. I'm no longer getting the 404 error because I had to change the ownership of directories under /usr/local/labkey to the tomcat user. So it looks like everything is working, only when I got to the url http://<ec2-instance>.compute-1.amazonaws.com:8080/labkey/ I get a white page. I don't see any errors in the tomcat (catalina) logs. What should I see on this page?

 
joesal responded:  2019-02-14 07:02

I think I've figured out the current problem by looking at the labkey.log file. It looks like the EC2 instance I have labkey setup on doesn't have access to the RDS instance. I'll update this thread once I figure out how to get that working.

 
joesal responded:  2019-02-14 13:12
Status: Closed

Problem solved. I had to set up a security group for rds that points to the security group id that was added to the ec2 instance! Now labkey server can connect to postgresql running on rds.

Hopefully this thread is helpful for others who are trying to get Labkey setup on aws with EC2 and RDS.