Import dataset with dateformat

General Server Forum (Inactive)
Import dataset with dateformat christine rousseau  2017-08-28 08:33
Status: Closed
Hi, I just finish to install Labkey and I try to begin with "Tutorial: Set Up a new study". I have a problem in Step 2 to import the dataset Demographics, I have the error "Could not convert 'Wed Jun 02 00:00:00 CEST 2004' for field date. should be of type TimeStamp". I try with your tutorail file (demographics.xls in LabKeyDemoFiles) and with a personal file. My Server configuration : - Ubuntu 16.04 - Labkey 17.1 - Java 1.8 - Tomcat 8 Web navigator : firefox 54.0.1 There are no errors in logs files. Could you tell me where could be my problem ? Thanks for your help. Best regards.
Jon (LabKey DevOps) responded:  2017-08-28 14:40
Hi Christine,

How are the values in the Date field formatted?

Is it literally "Wed Jun 02 00:00:00 CST 2004"? I'd like to setup a repro locally and confirm what you're getting based on what you have as your existing data.


Jon (LabKey DevOps) responded:  2017-08-28 14:43
Note: Initial test using the date as literally "Wed Jun 02 00:00:00 CEST 2004" did not bring up the same results.
christine rousseau responded:  2017-08-29 00:44

In my excel file (SUBJECTS_PERSONNAL_TEST.xls), date format yyyy-MM-dd
In your excel file (Demographics.xls), customized format yyyy-MM-dd

Date format in Labkey : I left the default format yyyy-MM-dd HH:MM

The error message "Wed Jun 02 00:00:00 CST 2004" is given by Labkey, I use nowhere this format.

Please find all attached the used files.
christine rousseau responded:  2017-08-30 08:23
I retry today step by step the tutorial "Set up a new study" with only your sample datas in

I have not made any changes in your file "demographics.xml", so the dates are in the correct format.
I am blocked in step 2 of this tutorial (Import Demographics dataset), you will find attached a screen copy of the error message (similar to that described above).

The timeZone in Postgres server is set to "Europe/Paris".

If I'm not mistaken, date format in Participant Table is set to 'TimeStamp without timezone'. This would mean that your INSERT request add timezone to the date ?

At this point I am completely blocked and I do not see how our institution could use Labkey if we can not import massively data via Excel files.

I hope you could help me to solve this problem.

Best regards.
Jon (LabKey DevOps) responded:  2017-08-30 13:44
Thanks for the additional details Christine. We have other clients outside of the US that are able to use our software successfully, so I think this may just be a configuration issue.

Let me dig into this further and get back to you as soon as I can.

Thank you for your patience.


christine rousseau responded:  2017-08-31 00:27
Thank for your help.

I'm waiting your response.

Best regards.

Jon (LabKey DevOps) responded:  2017-09-04 23:05
Hi Christine,

I tried setting my timezone and database to Europe/Paris and made sure the timezone was picked up by my local instance. That said, the error just couldn't come up for me, even with setting the Site Settings to match with the datetime formatting and using multiple browsers.

Is it possible for you to try and reproduce the error once more, then send me the labkey.log file from your server under the TOMCAT_HOME/logs directory? The logs will usually capture something, such as the error and the stack error behind it.


christine rousseau responded:  2017-09-05 05:17
Dear Jon,

Please find le labkey.log file.
I redo the same test with the demographics.xml file from your

Best regards.
Jon (LabKey DevOps) responded:  2017-09-11 00:20
Hi Christine,

Thank you for providing the log file. Unfortunately, the log doesn't contain any information that pertains to the error.

Your log did confirm that my previous setup using Paris time did set correctly since my timestamps in my log show CEST as well.

Is it possible for you to try one more thing?

Based on your screenshot "LabkeyErrorImport.JPG", it looks like you're running in Google Chrome.

Can you try to reproduce the same error again, but this time bring up the Google Developer Console before the error appears? Maybe we can capture the full stack error that gets outputted to the console to get more details to the error.

So far, my LabKey configuration isn't too far off from yours (i.e. Linux OS, updated PostgreSQL DB) and setting my timezone on both the database and the OS didn't trigger the same error, so I'm not sure what else is happening here that could trigger this behavior. But I am confident that the Developer Console should expose the error you're seeing in full.