insert data to server rqi  2018-04-20 07:35
Status: Closed

from labkey.query import insert_rows

I used insert_rows(server_context, schema, table, row) to insert my data.

It worked but usually it took 10 minutes to upload a small size data set like 50 kb. Is there any log file I can check what is happening in the 10 mins?

If I tried to upload 10 different data sets to the same table, it worked for the first data set but failed for the 2nd one. Exception said: 500: SqlExecutor.execute(); SQL []; An I/O error occurred while sending to the backend.; nested exception is org.postgresql.util.PSQLException: An I/O error occurred while sending to the backend.

What might be the reason? Many people said it might be connection issue. If yes, how can I try to solve the problem?

Thanks very much

Jon (LabKey DevOps) responded:  2018-04-27 15:04

What API are you using? It looks like you're calling on the Python API, but I'd like to confirm this with you.

The only logging that may show anything is the Audit Logs within the Admin Console area of LabKey, specifically the "Client API Actions", the localhost access logs and possibly the labkey.log file in the Tomcat Logs directory.

What exactly are you looking to check during those 10 minutes?

Do you have any more details on that 500 exception error? Like a full stack error? There is not enough detail in it to determine if it is a connection issue between you and the server, your server and the database, or something else entirely.