Captcha service broken

General Server Forum (Inactive)
Captcha service broken millerjw4  2020-02-11 06:47
Status: Active
 

Hello,

Our production instance of LabKey is having an issue with the Captcha service on the registration page. This production instance is on 19.3, and this error does not happen on 19.2.

I see the following stacktrace from a 500 error when LabKey calls the captcha service:

HTTP Status 500 – Internal Server Error
Type Exception Report

Message Servlet execution threw an exception

Description The server encountered an unexpected condition that prevented it from fulfilling the request.

Exception

javax.servlet.ServletException: Servlet execution threw an exception
        org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:53)
        org.labkey.api.module.ModuleLoader.doFilter(ModuleLoader.java:1226)
        org.labkey.api.security.AuthFilter.doFilter(AuthFilter.java:215)
        org.labkey.core.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:118)
Root Cause

java.lang.NoClassDefFoundError: Could not initialize class java.awt.image.BufferedImage
        com.google.code.kaptcha.text.impl.DefaultWordRenderer.renderWord(DefaultWordRenderer.java:37)
        com.google.code.kaptcha.impl.DefaultKaptcha.createImage(DefaultKaptcha.java:43)
        com.google.code.kaptcha.servlet.KaptchaServlet.doGet(KaptchaServlet.java:84)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:634)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:741)
        org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:53)
        org.labkey.api.module.ModuleLoader.doFilter(ModuleLoader.java:1226)
        org.labkey.api.security.AuthFilter.doFilter(AuthFilter.java:215)
        org.labkey.core.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:118)
Note The full stack trace of the root cause is available in the server logs.

Apache Tomcat/9.0.27


 
 
chetc (LabKey Support) responded:  2020-02-26 14:12

Hello,

Thank you for reaching out to us!

What version of Java do you have installed on the server running 19.3?
If you had 19.2 running on Java 12 and then upgraded to 19.3 without changing to Java 13, then that may explain why you are experiencing issues.
Please see https://www.labkey.org/Documentation/Archive/19.2/wiki-page.view?name=supported on our docs site for a complete list of supported technologies.

Thanks,
Chet

 
chetc (LabKey Support) responded:  2020-02-26 16:10

Hello,

Could you please send us the labkey.log file? This should be located in your tomcat directory (where you have tomcat installed) under logs.

Thanks,
Chet

 
chetc (LabKey Support) responded:  2020-03-06 10:30

Hello,

We appreciate you utilizing our forums!

However this forum will become inactive very soon. To follow up on this question or to ask new question please use our new forum.

LabKey Support Forum - https://www.labkey.org/home/Support/LabKey Support Forum/project-begin.view?

Thanks,
Chet