Non-responsive UI element (Knitr Options) when trying to create a new R report?

General Server Forum (Inactive)
Non-responsive UI element (Knitr Options) when trying to create a new R report? olnerdybastid  2018-08-21 14:32
Status: Closed

I am trying to learn a bit about creating R reports by following the tutorial here But I can't get past the step 'Specify which source to process with knitr. Under knitr Options, select HTML or Markdown', because when I'm on the Source tab, the 'expand node' icon on the Knitr Options bar is not functional. Nothing happens when I click the arrow to expand the node, so I can't view the Knitr config options to complete the rest of the steps. Any ideas why this is happening?

I'm on LabKey v18.1, and this is reproducible on every browser I've tried (Safari, Chrome, & Firefox, all on a Mac).

Jon (LabKey DevOps) responded:  2018-09-05 13:52

I think this issue is isolated to your local system since I'm unable to reproduce the conditions you described in 18.1 or any other version of LabKey in any browser when testing this locally on my Mac.

If you have any custom CSS or JS scripts running on your local instance of LabKey, that could potentially interfere with out-of-the-box features within LabKey depending on how you setup your own code.

I would recommend enabling a web debugger like Google's Developer Console and seeing whether you are pulling up any errors in trying to expand that item. If you do have any custom CSS or JS code running that is meant to enhance your LabKey experience, I would recommend disabling those features and then retrying your work in the RViewBuilder again.


olnerdybastid responded:  2018-09-09 13:41
Thanks for checking it out. I did some limited debugging on 18.1 and couldn't find anything in my JS/CSS that was disabling this button. But as it turns this is working as expected for me after upgrading to 18.2, so problem solved.