LabKey Trial Support


The Q&A forum below is inactive. If you have a question about using LabKey Trial or any other LabKey Server application, please post to the Community Support forum.

In order to post to the community forum, you'll need to register for a new account.  If you already have an account but have forgotten your password, you can reset your password using the link on the Sign in page.


Showing: all questions
'survey label' field from surveys.Surveys table
(1 response) rita alves 2020-01-09 05:56


Is there any possibility to automatically fill the question patientid using the 'survey label'? How to access to the survey label field?

{"name" : "patientid",
"caption" : "Patient ID:",
"required" : true,
"xtype": "textfield",

Thanks in advance

view question
Hide submit button
(1 response) rita alves 2020-01-08 03:07


Is there any possibility to hide the submit button in the survey (survey design code)?

Thanks in advance

view question
Issue when using alert within a function
(1 response) rita alves 2019-10-28 04:21

I have the following questions within a survey design code:

{"name" : "inidt",
  caption" : "Data de início:",
  "xtype": "datefield"},

              "fieldLabel": "Descontinuação?",
                  "inputValue": 1},
                 "inputValue": 0},
                 "inputValue": "NA"}]}},

            "name" : "discdt",
            "fieldLabel" : "Data de descontinuação:",
            "xtype": "datefield",
            "hidden": true},
          "listeners": {
             "change": {
               "question": "discquestion",
                  "fn" : "function(me, cmp, newValue, oldValue){var cmp2 = cmp.getValue(); if (cmp2.disc == 1) {me.setVisible(newValue); console.log(cmp2.disc);} else {me.setVisible(false);}} "}}},

                 {"name" : "obs",
                  "caption" : " ",
                  "xtype": "textareafield",
                 "grow" : true,
                 "width": 800,
                 "height": 200},
                "listeners": {
                     "change": {
                           "question": ["discdt","inidt"],
                          "fn" : "function(me, cmp, newValue, oldValue){var q1 = cmp.getName(); var q2 = cmp.getName(); if (q1 == 'inidt'){q1val = newValue; console.log(newValue);} else if (q2 == 'discdt'){q2val = newValue; console.log(newValue);}; if (q1val>=q2val){alert('nooooooo')};}; console.log(newValue); "}}}

I was trying to make question "discdt" visible only if disc = 1 (this is working). Although I would like to add a validation of the dates: discdt has to be more recent than inidt. This is working if i am creating a new survey. Howerver when I try to access a saved/submitted survey it is just "loading" (this is a problem cause I need to access the surveys after they are filled).

Could you please help?
Thank you!
view question
File Repository Sorting
(3 responses) vcleveland 2019-10-11 11:38

I am trying to setup a repository for MRI DICOM and 3D Mesh files. I am using some pictures from a camping trip as dummy files. I've added a few Properties (all single line text <10 characters) to test out the repository and to represent metadata later on. In the toolbar and grid settings I've checked those properties to be sortable. When working in the file repository I can not sort by the custom properties. When I try and sort by the property is just sorts by the file name instead.

My goal is to make a system where a user can sort and filter these files and download the results in bulk. I'll worry about more advanced features later.

view question
Plain text password in configuration.xml
(1 response) desmond fox 2019-10-04 07:58

Hello Support,

Our company does not allow us to store plain text passwords in files. Credentials must be always encrypted and then decrypted on the fly.
Does LabKey support encrypted credentials ?


view question
Labkey 19.2 - Apache Tomcat 9.0.24
(4 responses) Greg Otico 2019-09-11 12:51

Hello Support,

We recently deployed Labkey 19.2 in a clustered Apache Tomcat 9.0.24 environment. When we make changes (ie. add projects) it only appears on one node and we need to restart the 2nd node for changes to appear on it. Is there some sore of cache setting that needs to be adjusted>

Please advise.

Thanks, Greg

view question
Issues with running LabKey Python API
(1 response) ambarish nag 2019-09-10 09:52

I am trying to write the .netrc for my MacOSX laptop.
I have started a LabKey trial site called ‘ANag_LabKey_Trial’ accessible at

It is not clear to me what I should write in the line: machine <remote-instance-of-labkey-server>

When I use the following lines in the .netrc file:

password ********

I get the following error when I try to run the example case in

Can you please help me fix these errors ?

result = select_rows(server_context, schema, table)

Traceback (most recent call last):
File "/anaconda3/lib/python3.6/site-packages/urllib3/", line 159, in _new_conn
(self._dns_host, self.port), self.timeout, **extra_kw)
File "/anaconda3/lib/python3.6/site-packages/urllib3/util/", line 80, in create_connection
raise err
File "/anaconda3/lib/python3.6/site-packages/urllib3/util/", line 70, in create_connection
ConnectionRefusedError: [Errno 61] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/anaconda3/lib/python3.6/site-packages/urllib3/", line 600, in urlopen
File "/anaconda3/lib/python3.6/site-packages/urllib3/", line 354, in _make_request
conn.request(method, url, **httplib_request_kw)
File "/anaconda3/lib/python3.6/http/", line 1239, in request
self._send_request(method, url, body, headers, encode_chunked)
File "/anaconda3/lib/python3.6/http/", line 1285, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File "/anaconda3/lib/python3.6/http/", line 1234, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File "/anaconda3/lib/python3.6/http/", line 1026, in _send_output
File "/anaconda3/lib/python3.6/http/", line 964, in send
File "/anaconda3/lib/python3.6/site-packages/urllib3/", line 181, in connect
conn = self._new_conn()
File "/anaconda3/lib/python3.6/site-packages/urllib3/", line 168, in _new_conn
self, "Failed to establish a new connection: %s" % e)
urllib3.exceptions.NewConnectionError: <urllib3.connection.HTTPConnection object at 0x104777a90>: Failed to establish a new connection: [Errno 61] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/anaconda3/lib/python3.6/site-packages/requests/", line 449, in send
File "/anaconda3/lib/python3.6/site-packages/urllib3/", line 638, in urlopen
File "/anaconda3/lib/python3.6/site-packages/urllib3/util/", line 398, in increment
raise MaxRetryError(_pool, url, error or ResponseError(cause))
urllib3.exceptions.MaxRetryError: HTTPConnectionPool(host='localhost', port=8080): Max retries exceeded with url: /labkey/ModuleAssayTest/login-whoami.api (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x104777a90>: Failed to establish a new connection: [Errno 61] Connection refused',))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/anaconda3/lib/python3.6/site-packages/labkey/", line 93, in make_request
response = handle_response(self._session.get(csrf_url))
File "/anaconda3/lib/python3.6/site-packages/requests/", line 546, in get
return self.request('GET', url, **kwargs)
File "/anaconda3/lib/python3.6/site-packages/requests/", line 533, in request
resp = self.send(prep, **send_kwargs)
File "/anaconda3/lib/python3.6/site-packages/requests/", line 646, in send
r = adapter.send(request, **kwargs)
File "/anaconda3/lib/python3.6/site-packages/requests/", line 516, in send
raise ConnectionError(e, request=request)
requests.exceptions.ConnectionError: HTTPConnectionPool(host='localhost', port=8080): Max retries exceeded with url: /labkey/ModuleAssayTest/login-whoami.api (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x104777a90>: Failed to establish a new connection: [Errno 61] Connection refused',))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/anaconda3/lib/python3.6/site-packages/labkey/", line 286, in select_rows
return server_context.make_request(url, payload, timeout=timeout)
File "/anaconda3/lib/python3.6/site-packages/labkey/", line 98, in make_request
handle_request_exception(e, server_context=self)
File "/anaconda3/lib/python3.6/site-packages/labkey/", line 157, in handle_request_exception
raise ServerContextError(server_context, e)
labkey.exceptions.ServerContextError: 'Failed to connect to server. Ensure the server_context domain, context_path, and SSL are configured corr

view question
Suspected problems with Server.xml config
(1 response) david lee 2019-08-12 06:22

A newbie here. I'm working with my IT colleagues to set up LabKey Server. We have run through the manual install process with the online documentation. All seemed to go ok (except for the certificate security - but that's less important at the moment).

We are using LINUX App Server and Postgres SQL server.

We know tomcat is runningok as we can connect to the path: https://localServer:8443
But we get an "HTTP Status 404 – Not Found" when we try to access https://localServer:8443/labkey/

Any ideas on what we should be looking at - the IT guys want someone to lookover the Server.xml file. Is that something I can get help with here?


view question
Using a local R scripting engine
(1 response) nstafford 2019-07-25 11:49

I am using the trial version of labkey. I was hoping to set up some R Reports, but the Labkey trail R engine does not have the packages installed that I need. I tried to change the R scripting engine to my local R.exe, but it doesn't seem to be letting me do that. Is installing new packages/using a local R scripting engine possible with the labkey free trial? If not, what version of labkey would allow me to do this?

view question
Re-install Labkey
(1 response) rita alves 2019-07-19 06:05

The PC where Labkey was installed will need to be replaced.
Is it possible to migrate everything to a new machine? In case that is possible, how can we transfer everything from a machine to another one?

view question
Edit a Wiki
(1 response) rita alves 2019-07-19 06:04


Is it possible to lock the edition of a Wiki to a user who have "editor" permissions?
Thank you!

view question
Survey: Submitted to Pending
(1 response) rita alves 2019-06-03 01:34


Is there any option for an Administrator user to change the survey status from "Submitted" to "Pending"?


view question
xls columns not imported
(2 responses) cmarkwood 2019-04-24 10:34


I've set up a cloud trial server and project and am trying to import a simple .xls file into the Laboratory Data but only half of my columns are being imported. I believe that I've set the data type correctly. Some Strings come through, others don't and it's the same with Numbers (Double).
I've tried twice with the same result.


view question
Blank page when accessing Explore Sample Project
(1 response) frantz gabeau 2019-03-29 09:45

I'm getting a blank page when I click on the "Explore Sample Project" button at the Home page in the LabKey Biologics module.

view question
Remote Login API
(2 responses) craig.e.parman 2019-03-28 12:27

Hi am trying to test the Remote Login API as described in the documentation here:

I have tried it on my hosted trial version and on a local VirtualBox VM. No matter what I put int for the returnUrl I get

"Error: a valid returnUrl was not specified."

Is there a configuration setting I must use?


view question
"Send notification emails to all new users" does not work
(1 response) wangxn 2019-03-20 12:49

We installed LabKey v 18.3 and set ldap login. When I add a new user, the "Send notification emails to all new users" does not work. I tested
"Test Email Configuration" and it was able to send an email. It appears no packet sent out when used "Send notification emails to all new users" to invite a new user.

Thanks for anyone if would help,

view question
Two columns mapped error
(1 response) sadams7703 2018-12-17 09:35

When I try to upload datasets I get an error message "Two columns mapped to target column: ptid_full".
I am not sure why this is. "ptid_full" is the subject ID as defined in the Study Properties.
There is a second column in the Excel sheet named "ptid" as you can see in the screen shot. Deleting this column in Excel fixes the problem, but I don't understand why LabKey is trying to map two columns instead of only the "ptid_full" column.

Additional finding-- renaming the column "ptid" to "ptidnum" in Excel (instead of deleting) also allows upload.

view question
Participants not cleanly deleted?
(1 response) sadams7703 2018-12-01 17:23

In learning with the trial I have uploaded some data then wanted to delete it. However when I delete it the participants remain. See attached screenshot which says "clean data tracks data in 0 datasets over 1 visit. Data is present for 214 Participants. "

This is after uploading a dataset, using the file to create the dataset, and then using Manage to delete to dataset.
What is the reason these participants will not disappear?

view question
Unexpected Error when deleting folders or subfolders
(2 responses) sadams7703 2018-12-01 06:08

Hi, When I use the Admin>Folder>Management and try to delete any folder or subfolder I receive "500: Unexpected Server Error" following the confirm deletion page. Nothing is deleted.
This is on Firefox 63.0.3 on Windows.

view question
branch of existing Labkey notebook for new lab
(1 response) emohr 2018-07-16 14:45


I am a member of David O'Connor's group from UW Madison. I am branching into my own space and Dave has helped me be setting up a labkey lab notebook under his master agreement, but said I needed to link it to server space before doing it. I will be working with my pediatrics department IT people to set up this storage and am wondering how this is actually done.


view question
Trying to create a survey with trial version
(1 response) dkh 2018-06-14 12:25

Hi. I am trying to create a survey with the trial version, but cannot see how I can 'Under Modules, place a checkmark next to Survey' or 'Add a Survey Designs web part'. I was able to 'Create a new Lists web part' and import some data.

view question
Assay type/Assay design
(1 response) tanyaj 92 2018-05-23 13:52

Hi, i am trying to use my LabKey trial version to set up an assay to analyse Luminex data. I am following the Luminex assay tutorial level 1, and it tells me to select 'Luminex' in my assay type under New Assay Design. I am unable o locate this feature, and can only see a 'General' assay type.
Please help!!!

view question
Registering for a Trial
(1 response) kelseyg 2018-02-12 10:56
Tell us about your experience registering for a trial. Were you successful? Did the UI function as you expected? Did you need any additional directions to be successful?
view question
Exploring the Example Project
(2 responses) kelseyg 2018-02-12 10:55
Tell us about your experience exploring the example project. Were you successful? Did the UI function as you expected? Did you need any additional documentation to be successful?
view question


LabKey Server
Tours and tutorials provide step-by-step walkthroughs of key functionality in LabKey Server. These resources will help you familiarize yourself with actions like uploading assay data and creating LabKey studies.

Tours & Tutorials

Below are current known issues with the LabKey trial manager application: 

Problem: After resetting a LabKey password, users are not automatically redirected back to their LabKey trial homepage

Workaround: Reset password is opened in a new tab. When complete, return to the original login page, refresh, and log in with your new password.